CVE-2014-8542

NameCVE-2014-8542
Descriptionlibavcodec/utils.c in FFmpeg before 2.4.2 omits a certain codec ID during enforcement of alignment, which allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted JV data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1654-1
NVD severityhigh
Debian Bugs773626

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.15-0+deb9u4fixed
buster, buster (security)7:4.1.6-1~deb10u1fixed
bullseye7:4.3.2-0+deb11u2fixed
bookworm, sid7:4.4-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcesqueeze(unfixed)end-of-life
ffmpegsource(unstable)7:2.4.3-1
libavsourcewheezy(not affected)
libavsourcejessie6:11.12-1~deb8u5DLA-1654-1
libavsource(unstable)6:11.2-1773626

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
[wheezy] - libav <not-affected> (Vulnerable code not present)
ffmpeg: https://git.videolan.org/?p=ffmpeg.git;a=commit;h=105654e376a736d243aef4a1d121abebce912e6b
libav: https://git.libav.org/?p=libav.git;a=commit;h=88626e5af8d006e67189bf10b96b982502a7e8ad

Search for package or bug name: Reporting problems