CVE-2014-8546

NameCVE-2014-8546
DescriptionInteger underflow in libavcodec/cinepak.c in FFmpeg before 2.4.2 allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted Cinepak video data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.15-0+deb9u4fixed
buster7:4.1.6-1~deb10u1fixed
buster (security)7:4.1.8-0+deb10u1fixed
bullseye7:4.3.2-0+deb11u2fixed
bookworm, sid7:4.4-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcesqueeze(unfixed)end-of-life
ffmpegsource(unstable)7:2.4.3-1
libavsource(unstable)(not affected)

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
- libav <not-affected> (Vulnerable code not present, reproducer tested with 8, 11 and trunk)
ffmpeg: https://git.videolan.org/?p=ffmpeg.git;a=commit;h=e7e5114c506957f40aafd794e06de1a7e341e9d5

Search for package or bug name: Reporting problems