CVE-2014-8547

NameCVE-2014-8547
Descriptionlibavcodec/gifdec.c in FFmpeg before 2.4.2 does not properly compute image heights, which allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted GIF data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3189-1
NVD severityhigh (attack range: remote)
Debian Bugs773626

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.7-1~deb9u1fixed
stretch (security)7:3.2.8-1~deb9u1fixed
buster, sid7:3.3.4-2fixed
libav (PTS)wheezy6:0.8.17-2fixed
wheezy (security)6:0.8.20-0+deb7u1fixed
jessie (security), jessie6:11.9-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.3-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:11.2-1high773626
libavsourcewheezy6:0.8.17-1highDSA-3189-1

Notes

[squeeze] - ffmpeg <end-of-life> (Backports to 0.5.x not useful, too many checks missing)
ffmpeg: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=8f1457864be8fb9653643519dea1c6492f1dde57
libav: https://git.libav.org/?p=libav.git;a=commit;h=0b39ac6f54505a538c21fe49a626de94c518c903

Search for package or bug name: Reporting problems