CVE-2014-8562

NameCVE-2014-8562
DescriptionDCM decode in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-242-1, DLA-960-1
NVD severitymedium (attack range: remote)
Debian Bugs767240

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.8.9.9-1medium767240
imagemagicksourcesqueeze8:6.6.0.4-3+squeeze6mediumDLA-242-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u13mediumDLA-960-1

Notes

[squeeze] - imagemagick <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems