CVE-2014-8601

NameCVE-2014-8601
DescriptionPowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote attackers to cause a denial of service ("performance degradations") via a large or infinite number of referrals, as demonstrated by resolving domains hosted by ezdns.it.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-104-1, DSA-3096-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns-recursor (PTS)wheezy3.3-3+deb7u1fixed
wheezy (security)3.3-3+deb7u2fixed
jessie (security), jessie3.6.2-2+deb8u3fixed
stretch4.0.4-1+deb9u1fixed
buster, sid4.0.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdns-recursorsource(unstable)3.6.2-1medium
pdns-recursorsourcesqueeze3.2-4+deb6u1mediumDLA-104-1
pdns-recursorsourcewheezy3.3-3+deb7u1mediumDSA-3096-1

Notes

http://doc.powerdns.com/md/security/powerdns-advisory-2014-02/
Backported patches available at https://downloads.powerdns.com/patches/2014-02/

Search for package or bug name: Reporting problems