CVE-2014-8602

NameCVE-2014-8602
Descriptioniterator.c in NLnet Labs Unbound before 1.5.1 does not limit delegation chaining, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a large or infinite number of referrals.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-107-1, DSA-3097-1
NVD severitymedium (attack range: remote)
Debian Bugs772622

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)wheezy, wheezy (security)1.4.17-3+deb7u2fixed
jessie1.4.22-3+deb8u2fixed
stretch1.6.0-3+deb9u1fixed
buster1.6.6-1fixed
sid1.6.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsource(unstable)1.4.22-3medium772622
unboundsourcesqueeze1.4.6-1+squeeze4mediumDLA-107-1
unboundsourcewheezy1.4.17-3+deb7u2mediumDSA-3097-1

Notes

http://www.unbound.net/pipermail/unbound-users/2014-December/003662.html

Search for package or bug name: Reporting problems