CVE-2014-8625

NameCVE-2014-8625
DescriptionMultiple format string vulnerabilities in the parse_error_msg function in parsehelp.c in dpkg before 1.17.22 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via format string specifiers in the (1) package or (2) architecture name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs768485

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpkg (PTS)jessie1.17.27fixed
jessie (security)1.17.26fixed
stretch1.18.24fixed
buster, sid1.19.0.5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpkgsource(unstable)1.17.22unimportant768485
dpkgsourcesqueeze(not affected)
dpkgsourcewheezy1.16.16medium

Notes

[squeeze] - dpkg <not-affected> (Regression introduced in 1.16.2)
Rendered non-exploitable by toolchain hardening
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/1389135
Regression introduced with https://anonscm.debian.org/cgit/dpkg/dpkg.git/commit/?id=0b8652b226a7601dfd71471797d15168a7337242 (1.16.2)

Search for package or bug name: Reporting problems