DescriptionPolarSSL 1.3.8 does not properly negotiate the signature algorithm to use, which allows remote attackers to conduct downgrade attacks via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
polarssl (PTS)wheezy, wheezy (security)1.2.9-1~deb7u6fixed
jessie (security)1.3.9-2.1+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
polarsslsourcesqueeze(not affected)
polarsslsourcewheezy(not affected)


[wheezy] - polarssl <not-affected> (Problem introduced in 1.3.8)
[squeeze] - polarssl <not-affected> (Problem introduced in 1.3.8)

Search for package or bug name: Reporting problems