CVE-2014-8711

NameCVE-2014-8711
DescriptionMultiple integer overflows in epan/dissectors/packet-amqp.c in the AMQP dissector in Wireshark 1.10.x before 1.10.11 and 1.12.x before 1.12.2 allow remote attackers to cause a denial of service (application crash) via a crafted amqp_0_10 PDU in a packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-198-1, DSA-3076-1
NVD severitymedium (attack range: remote)
Debian Bugs769410

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie1.12.1+g01b65bf-4+deb8u11fixed
jessie (security)1.12.1+g01b65bf-4+deb8u12fixed
stretch2.2.6+g32dac6a-2fixed
stretch (security)2.2.6+g32dac6a-2+deb9u1fixed
buster, sid2.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.12.1+g01b65bf-2medium769410
wiresharksourcesqueeze1.8.2-5wheezy15~deb6u1mediumDLA-198-1
wiresharksourcewheezy1.8.2-5wheezy13mediumDSA-3076-1

Notes

https://www.wireshark.org/security/wnpa-sec-2014-21.html
Versions 1.12.0 to 1.12.1, and 1.10.0 to 1.10.10. It is fixed in versions 1.12.2 and 1.10.11.

Search for package or bug name: Reporting problems