CVE-2014-8767

NameCVE-2014-8767
DescriptionInteger underflow in the olsr_print function in tcpdump 3.9.6 through 4.6.2, when in verbose mode, allows remote attackers to cause a denial of service (crash) via a crafted length value in an OLSR frame.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-102-1, DSA-3086-1
NVD severitymedium (attack range: remote)
Debian Bugs770434

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)wheezy4.3.0-1+deb7u2fixed
wheezy (security)4.9.2-1~deb7u1fixed
jessie4.9.0-1~deb8u1fixed
jessie (security)4.9.2-1~deb8u1fixed
stretch (security), stretch4.9.2-1~deb9u1fixed
buster, sid4.9.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)4.6.2-2medium770434
tcpdumpsourcesqueeze4.1.1-1+deb6u1mediumDLA-102-1
tcpdumpsourcewheezy4.3.0-1+deb7u1mediumDSA-3086-1

Notes

http://www.securityfocus.com/archive/1/534011/30/0/threaded

Search for package or bug name: Reporting problems