CVE-2014-8866

NameCVE-2014-8866
DescriptionThe compatibility mode hypercall argument translation in Xen 3.3.x through 4.4.x, when running on a 64-bit hypervisor, allows local 32-bit HVM guests to cause a denial of service (host crash) via vectors involving altering the high halves of registers while in 64-bit mode.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3140-1
NVD severitymedium (attack range: local)
Debian Bugs770230

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-8fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1fixed
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.4.1-5medium770230
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u4mediumDSA-3140-1

Notes

[squeeze] - xen <end-of-life> (Unsupported in squeeze-lts)

Search for package or bug name: Reporting problems