CVE-2014-8958

NameCVE-2014-8958
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.6, 4.1.x before 4.1.14.7, and 4.2.x before 4.2.12 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database, (2) table, or (3) column name that is improperly handled during rendering of the table browse page; a crafted ENUM value that is improperly handled during rendering of the (4) table print view or (5) zoom search page; or (6) a crafted pma_fontsize cookie that is improperly handled during rendering of the home page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-336-1, DSA-3382-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)wheezy4:3.4.11.1-2+deb7u2fixed
wheezy (security)4:3.4.11.1-2+deb7u8fixed
jessie (security), jessie4:4.2.12-2+deb8u2fixed
stretch4:4.6.6-4fixed
buster, sid4:4.6.6-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.2.12-1low
phpmyadminsourcejessie4:4.2.12-2+deb8u1mediumDSA-3382-1
phpmyadminsourcesqueeze4:3.3.7-9mediumDLA-336-1
phpmyadminsourcewheezy4:3.4.11.1-2+deb7u2mediumDSA-3382-1

Notes

http://www.phpmyadmin.net/home_page/security/PMASA-2014-13.php
https://github.com/phpmyadmin/phpmyadmin/commit/42b64e12b5f596366f94ef72365fd69a019ba820 and
https://github.com/phpmyadmin/phpmyadmin/commit/c7685e5acd3f8e722f4f374c6fa821590865b68d need
to be backported to 3.4

Search for package or bug name: Reporting problems