CVE-2014-8962

NameCVE-2014-8962
DescriptionStack-based buffer overflow in stream_decoder.c in libFLAC before 1.3.1 allows remote attackers to execute arbitrary code via a crafted .flac file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-99-1, DSA-3082-1
NVD severityhigh (attack range: remote)
Debian Bugs770918

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flac (PTS)wheezy, wheezy (security)1.2.1-6+deb7u1fixed
jessie1.3.0-3fixed
buster, sid, stretch1.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flacsource(unstable)1.3.0-3high770918
flacsourcesqueeze1.2.1-2+deb6u1highDLA-99-1
flacsourcewheezy1.2.1-6+deb7u1highDSA-3082-1

Notes

https://git.xiph.org/?p=flac.git;a=patch;h=5b3033a2b355068c11fe637e14ac742d273f076e
http://lists.xiph.org/pipermail/flac-dev/2014-November/005185.html

Search for package or bug name: Reporting problems