CVE-2014-9029

NameCVE-2014-9029
DescriptionMultiple off-by-one errors in the (1) jpc_dec_cp_setfromcox and (2) jpc_dec_cp_setfromrgn functions in jpc/jpc_dec.c in JasPer 1.900.1 and earlier allow remote attackers to execute arbitrary code via a crafted jp2 file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-101-1, DSA-3089-1
NVD severityhigh (attack range: remote)
Debian Bugs772036

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jasper (PTS)wheezy1.900.1-13+deb7u4fixed
wheezy (security)1.900.1-13+deb7u6fixed
jessie (security), jessie1.900.1-debian1-2.4+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jaspersource(unstable)1.900.1-debian1-2.2high772036
jaspersourcesqueeze1.900.1-7+squeeze2highDLA-101-1
jaspersourcewheezy1.900.1-13+deb7u1highDSA-3089-1

Search for package or bug name: Reporting problems