CVE-2014-9031

NameCVE-2014-9031
DescriptionCross-site scripting (XSS) vulnerability in the wptexturize function in WordPress before 3.7.5, 3.8.x before 3.8.5, and 3.9.x before 3.9.3 allows remote attackers to inject arbitrary web script or HTML via crafted use of shortcode brackets in a text field, as demonstrated by a comment or a post.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-236-1, DSA-3085-1
NVD severitymedium (attack range: remote)
Debian Bugs770425

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u20fixed
jessie4.1+dfsg-1+deb8u15fixed
jessie (security)4.1+dfsg-1+deb8u16fixed
stretch4.7.5+dfsg-2+deb9u1fixed
stretch (security)4.7.5+dfsg-2+deb9u2fixed
buster, sid4.9.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.0.1+dfsg-1medium770425
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u6mediumDLA-236-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u5mediumDSA-3085-1

Notes

https://wordpress.org/news/2014/11/wordpress-4-0-1/

Search for package or bug name: Reporting problems