CVE-2014-9039

NameCVE-2014-9039
Descriptionwp-login.php in WordPress before 3.7.5, 3.8.x before 3.8.5, 3.9.x before 3.9.3, and 4.x before 4.0.1 might allow remote attackers to reset passwords by leveraging access to an e-mail account that received a password-reset message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-236-1, DSA-3085-1
NVD severitymedium (attack range: remote)
Debian Bugs770425

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.0.1+dfsg-1medium770425
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u6mediumDLA-236-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u5mediumDSA-3085-1

Notes

Upstream patch: http://core.trac.wordpress.org/changeset/30431
https://wordpress.org/news/2014/11/wordpress-4-0-1/

Search for package or bug name: Reporting problems