CVE-2014-9050

NameCVE-2014-9050
DescriptionHeap-based buffer overflow in the cli_scanpe function in libclamav/pe.c in ClamAV before 0.98.5 allows remote attackers to cause a denial of service (crash) via a crafted y0da Crypter PE file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-95-1
NVD severitymedium (attack range: remote)
Debian Bugs770985

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)wheezy0.99+dfsg-0+deb7u2fixed
wheezy (security)0.99.2+dfsg-0+deb7u3fixed
jessie0.99.2+dfsg-0+deb8u2fixed
stretch0.99.2+dfsg-6fixed
buster, sid0.99.3~beta1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.98.5+dfsg-1medium770985
clamavsourcesqueeze0.98.1+dfsg-1+deb6u4mediumDLA-95-1
clamavsourcewheezy0.98.5+dfsg-0+deb7u1medium

Notes

https://bugzilla.clamav.net/show_bug.cgi?id=11155
Upstream commit: https://github.com/vrtadmin/clamav-devel/commit/fc3794a54d2affe5770c1f876484a871c783e91e

Search for package or bug name: Reporting problems