CVE-2014-9087

NameCVE-2014-9087
DescriptionInteger underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-141-1, DSA-3078-1
NVD severitymedium (attack range: remote)
Debian Bugs770972

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg2 (PTS)wheezy, wheezy (security)2.0.19-2+deb7u2fixed
jessie2.0.26-6+deb8u1fixed
stretch2.1.18-8~deb9u1fixed
buster, sid2.2.1-2fixed
libksba (PTS)wheezy1.2.0-2+deb7u1fixed
wheezy (security)1.2.0-2+deb7u2fixed
jessie1.3.2-1+deb8u1fixed
buster, sid, stretch1.3.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupg2source(unstable)(not affected)
libksbasource(unstable)1.3.2-1medium770972
libksbasourcesqueeze1.0.7-2+deb6u1mediumDLA-141-1
libksbasourcewheezy1.2.0-2+deb7u1mediumDSA-3078-1

Notes

- gnupg2 <not-affected> (Fixed before entering unstable; affected only 2.1 and betas)
http://lists.gnupg.org/pipermail/gnupg-announce/2014q4/000359.html
Upstream commit: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=f715b9e156dfa99ae829fc694e5a0abd23ef97d7

Search for package or bug name: Reporting problems