DescriptionInteger underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to cause a denial of service (crash) via a crafted OID in a (1) S/MIME message or (2) ECC based OpenPGP data, which triggers a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-141-1, DSA-3078-1
NVD severitymedium (attack range: remote)
Debian Bugs770972

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg2 (PTS)jessie (security), jessie2.0.26-6+deb8u2fixed
stretch (security), stretch2.1.18-8~deb9u2fixed
buster, sid2.2.8-3fixed
libksba (PTS)jessie1.3.2-1+deb8u1fixed
buster, stretch, sid1.3.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupg2source(unstable)(not affected)


- gnupg2 <not-affected> (Fixed before entering unstable; affected only 2.1 and betas)
Upstream commit:;a=commit;h=f715b9e156dfa99ae829fc694e5a0abd23ef97d7

Search for package or bug name: Reporting problems