CVE-2014-9114

NameCVE-2014-9114
DescriptionBlkid in util-linux before 2.26rc-1 allows local users to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs771274

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)buster2.33.1-0.1fixed
buster (security)2.33.1-0.1+deb10u1fixed
bullseye2.36.1-8+deb11u1fixed
bullseye (security)2.36.1-8+deb11u2fixed
bookworm2.38.1-5fixed
bookworm (security)2.38.1-5+deb12u1fixed
trixie2.39.3-6fixed
sid2.40-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsource(unstable)2.25.2-4771274

Notes

[squeeze] - util-linux <no-dsa> (Minor issue)
[wheezy] - util-linux <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2014/11/26/13
https://github.com/karelzak/util-linux/commit/89e90ae7b2826110ea28c1c0eb8e7c56c3907bdc

Search for package or bug name: Reporting problems