CVE-2014-9140

NameCVE-2014-9140
DescriptionBuffer overflow in the ppp_hdlc function in print-ppp.c in tcpdump 4.6.2 and earlier allows remote attackers to cause a denial of service (crash) cia a crafted PPP packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-102-1, DSA-3086-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)wheezy4.3.0-1+deb7u2fixed
wheezy (security)4.9.2-1~deb7u1fixed
jessie4.9.0-1~deb8u1fixed
jessie (security)4.9.2-1~deb8u1fixed
stretch (security), stretch4.9.2-1~deb9u1fixed
buster, sid4.9.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)4.6.2-3medium
tcpdumpsourcesqueeze4.1.1-1+deb6u1mediumDLA-102-1
tcpdumpsourcewheezy4.3.0-1+deb7u1mediumDSA-3086-1

Notes

https://github.com/the-tcpdump-group/tcpdump/commit/0f95d441e4b5d7512cc5c326c8668a120e048eda
http://seclists.org/tcpdump/2014/q4/72

Search for package or bug name: Reporting problems