CVE-2014-9218

NameCVE-2014-9218
Descriptionlibraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.7, 4.1.x before 4.1.14.8, and 4.2.x before 4.2.13.1 allows remote attackers to cause a denial of service (resource consumption) via a long password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-336-1, DSA-3382-1
NVD severitymedium (attack range: remote)
Debian Bugs774194

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)wheezy4:3.4.11.1-2+deb7u2fixed
wheezy (security)4:3.4.11.1-2+deb7u8fixed
jessie (security), jessie4:4.2.12-2+deb8u2fixed
stretch4:4.6.6-4fixed
buster, sid4:4.6.6-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.2.12-2low774194
phpmyadminsourcejessie4:4.2.12-2+deb8u1mediumDSA-3382-1
phpmyadminsourcesqueeze4:3.3.7-9mediumDLA-336-1
phpmyadminsourcewheezy4:3.4.11.1-2+deb7u2mediumDSA-3382-1

Notes

https://github.com/phpmyadmin/phpmyadmin/commit/1ac863c7573d12012374d5d41e5c7dc5505ea6e1 (master)
http://www.phpmyadmin.net/home_page/security/PMASA-2014-17.php

Search for package or bug name: Reporting problems