CVE-2014-9221

NameCVE-2014-9221
DescriptionstrongSwan 4.5.x through 5.2.x before 5.2.1 allows remote attackers to cause a denial of service (invalid pointer dereference) via a crafted IKEv2 Key Exchange (KE) message with Diffie-Hellman (DH) group 1025.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3118-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)wheezy4.5.2-1.5+deb7u8fixed
wheezy (security)4.5.2-1.5+deb7u10fixed
jessie5.2.1-6+deb8u4fixed
jessie (security)5.2.1-6+deb8u5fixed
stretch (security), stretch5.5.1-4+deb9u1fixed
buster, sid5.6.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.2.1-5medium
strongswansourcesqueeze(not affected)
strongswansourcewheezy4.5.2-1.5+deb7u6mediumDSA-3118-1

Notes

[squeeze] - strongswan <not-affected> (MODP_CUSTOM Diffie-Hellman group not implemented in 4.4.1)

Search for package or bug name: Reporting problems