CVE-2014-9277

NameCVE-2014-9277
DescriptionThe wfMangleFlashPolicy function in OutputHandler.php in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7 allows remote attackers to conduct PHP object injection attacks via a crafted string containing <cross-domain-policy> in a PHP format request, which causes the string length to change when converting the request to <NOT-cross-domain-policy>.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3100-1
NVD severityhigh (attack range: remote)
Debian Bugs772764

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3fixed
stretch (security), stretch1:1.27.4-1~deb9u1fixed
buster, sid1:1.27.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.20+dfsg-2.1high772764
mediawikisourcesqueeze(unfixed)end-of-life
mediawikisourcewheezy1:1.19.20+dfsg-0+deb7u2highDSA-3100-1

Notes

https://bugzilla.wikimedia.org/show_bug.cgi?id=71478
backported patches for 1.19:
https://gerrit.wikimedia.org/r/#/c/175725/
https://gerrit.wikimedia.org/r/#/c/175960/

Search for package or bug name: Reporting problems