CVE-2014-9295

NameCVE-2014-9295
DescriptionMultiple stack-based buffer overflows in ntpd in NTP before 4.2.8 allow remote attackers to execute arbitrary code via a crafted packet, related to (1) the crypto_recv function when the Autokey Authentication feature is used, (2) the ctl_putdata function, and (3) the configure function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-116-1, DSA-3108-1
NVD severityhigh (attack range: remote)
Debian Bugs773576

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)wheezy1:4.2.6.p5+dfsg-2+deb7u6fixed
wheezy (security)1:4.2.6.p5+dfsg-2+deb7u7fixed
jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u1fixed
buster, sid1:4.2.8p10+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.6.p5+dfsg-3.2high773576
ntpsourcesqueeze1:4.2.6.p2+dfsg-1+deb6u1highDLA-116-1
ntpsourcewheezy1:4.2.6.p5+dfsg-2+deb7u1highDSA-3108-1

Notes

http://bugs.ntp.org/show_bug.cgi?id=2667 (not yet open)
http://bugs.ntp.org/show_bug.cgi?id=2668 (not yet open)
http://bugs.ntp.org/show_bug.cgi?id=2669 (not yet open)

Search for package or bug name: Reporting problems