CVE-2014-9319

NameCVE-2014-9319
DescriptionThe ff_hevc_decode_nal_sps function in libavcodec/hevc_ps.c in FFMpeg before 2.1.6, 2.2.x through 2.3.x, and 2.4.x before 2.4.4 allows remote attackers to cause a denial of service (out-of-bounds access) via a crafted .bit file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1fixed
stretch (security)7:3.2.16-1+deb9u1fixed
buster7:4.1.6-1~deb10u1fixed
buster (security)7:4.1.8-0+deb10u1fixed
bullseye (security), bullseye7:4.3.3-0+deb11u1fixed
bookworm, sid7:4.4.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcesqueeze(not affected)
ffmpegsource(unstable)2.4.4-1
libavsource(unstable)(not affected)

Notes

- libav <not-affected> (Vulnerable code not present, reproducer tested with 8, 11 and trunk)
[squeeze] - ffmpeg <not-affected> (Vulnerable code not present)
ffmpeg: https://git.videolan.org/?p=ffmpeg.git;a=commit;h=ea38e5a6b75706477898eb1e6582d667dbb9946c

Search for package or bug name: Reporting problems