CVE-2014-9380

NameCVE-2014-9380
DescriptionThe dissector_cvs function in dissectors/ec_cvs.c in Ettercap 0.8.1 allows remote attackers to cause a denial of service (out-of-bounds read) via a packet containing only a CVS_LOGIN signature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-126-1
NVD severitymedium
Debian Bugs773416

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ettercap (PTS)stretch1:0.8.2-6fixed
buster1:0.8.2-10fixed
bullseye, sid1:0.8.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ettercapsourcesqueeze1:0.7.3-2.1+squeeze2DLA-126-1
ettercapsource(unstable)1:0.8.1-3773416

Notes

Patch for squeeze in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773416#20

Search for package or bug name: Reporting problems