CVE-2014-9403

NameCVE-2014-9403
DescriptionThe CWebAdminMod::ChanPage function in modules/webadmin.cpp in ZNC before 1.4 allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) by adding a channel with the same name as an existing channel but without the leading # character, related to a "use-after-delete" error.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs744712

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
znc (PTS)stretch (security), stretch1.6.5-1+deb9u2fixed
buster1.7.2-3fixed
bullseye, sid1.8.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zncsource(unstable)1.2-4744712

Notes

[wheezy] - znc <no-dsa> (Minor issue)
[squeeze] - znc <no-dsa> (Minor issue)
https://github.com/znc/znc/issues/528
https://github.com/znc/znc/commit/8756be513ab6663dcd64087006b257ff34e8e487

Search for package or bug name: Reporting problems