CVE-2014-9462

NameCVE-2014-9462
DescriptionThe _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-237-1, DSA-3257-1
NVD severityhigh (attack range: remote)
Debian Bugs783237

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)wheezy2.2.2-4+deb7u2fixed
wheezy (security)2.2.2-4+deb7u5fixed
jessie3.1.2-2+deb8u3fixed
jessie (security)3.1.2-2+deb8u4fixed
stretch (security), stretch4.0-1+deb9u1fixed
buster, sid4.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)3.4-1high783237
mercurialsourcejessie3.1.2-2+deb8u1highDSA-3257-1
mercurialsourcesqueeze1.6.4-1+deb6u1highDLA-237-1
mercurialsourcewheezy2.2.2-4+deb7u1highDSA-3257-1

Notes

http://chargen.matasano.com/chargen/2015/3/17/this-new-vulnerability-mercurial-command-injection-cve-2014-9462.html
http://selenic.com/hg/rev/e3f30068d2eb

Search for package or bug name: Reporting problems