CVE-2014-9474

NameCVE-2014-9474
DescriptionBuffer overflow in the mpfr_strtofr function in GNU MPFR before 3.1.2-p11 allows context-dependent attackers to have unspecified impact via vectors related to incorrect documentation for mpn_set_str.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs772008

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mpfr4 (PTS)jessie3.1.2-2fixed
stretch3.1.5-1fixed
buster, sid4.0.2~rc1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mpfr4source(unstable)3.1.2-2low772008

Notes

[squeeze] - mpfr4 <no-dsa> (Minor issue)
[wheezy] - mpfr4 <no-dsa> (Minor issue)
https://gforge.inria.fr/scm/viewvc.php?view=rev&root=mpfr&revision=9243

Search for package or bug name: Reporting problems