CVE-2014-9488

NameCVE-2014-9488
DescriptionThe is_utf8_well_formed function in GNU less before 475 allows remote attackers to have unspecified impact via malformed UTF-8 characters, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs780247

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
less (PTS)jessie458-3vulnerable
stretch481-2.1fixed
buster, sid487-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lesssource(unstable)481-1unimportant780247

Notes

http://www.openwall.com/lists/oss-security/2015/03/10/14
https://blog.fuzzing-project.org/3-less-out-of-bounds-read-access-TFPA-0022014.html

Search for package or bug name: Reporting problems