CVE-2014-9571

NameCVE-2014-9571
DescriptionCross-site scripting (XSS) vulnerability in admin/install.php in MantisBT before 1.2.19 and 1.3.x before 1.3.0-beta.2 allows remote attackers to inject arbitrary web script or HTML via the (1) admin_username or (2) admin_password parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs780875

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mantis (PTS)wheezy1.2.18-1vulnerable
wheezy (security)1.2.18-1+deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mantissource(unstable)(unfixed)medium780875
mantissourcesqueeze(unfixed)end-of-life

Notes

[wheezy] - mantis <no-dsa> (Minor issue)
[squeeze] - mantis <end-of-life> (Unsupported in squeeze-lts)
Upstream patch: http://github.com/mantisbt/mantisbt/commit/6d47c047 (1.2.x)
https://www.mantisbt.org/bugs/view.php?id=17938

Search for package or bug name: Reporting problems