CVE-2014-9601

NameCVE-2014-9601
DescriptionPillow before 2.7.0 allows remote attackers to cause a denial of service via a compressed text chunk in a PNG image that has a large size when it is decompressed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs776303

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)buster, buster (security)5.4.1-2+deb10u3fixed
bullseye (security), bullseye8.1.2+dfsg-0.3+deb11u1fixed
bookworm, sid9.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)2.6.1-2776303
python-imagingsource(unstable)(unfixed)

Notes

[wheezy] - python-imaging <no-dsa> (Minor issue)
[squeeze] - python-imaging <no-dsa> (Minor issue)
https://github.com/python-pillow/Pillow/commit/b3e09122e527ae554eb590741bbd7611d5710e40
http://web.archive.org/web/20150921104441/http://pillow.readthedocs.org:80/releasenotes/2.7.0.html#png-text-chunk-size-limits

Search for package or bug name: Reporting problems