CVE-2014-9604

NameCVE-2014-9604
Descriptionlibavcodec/utvideodec.c in FFmpeg before 2.5.2 does not check for a zero value of a slice height, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted Ut Video data, related to the (1) restore_median and (2) restore_median_il functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3189-1
NVD severityhigh (attack range: remote)
Debian Bugs775593

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.7-1~deb9u1fixed
stretch (security)7:3.2.8-1~deb9u1fixed
buster, sid7:3.3.4-2fixed
libav (PTS)wheezy6:0.8.17-2fixed
wheezy (security)6:0.8.21-0+deb7u1fixed
jessie (security), jessie6:11.9-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.5.1-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)6:11.3-1high775593
libavsourcewheezy6:0.8.17-1highDSA-3189-1

Notes

[squeeze] - ffmpeg <end-of-life> (Not supported in Squeeze LTS)
Applies to 0.8, but in different file (utvideo.c)
libav: https://git.libav.org/?p=libav.git;a=commit;h=0ce3a0f9d9523a9bcad4c6d451ca5bbd7a4f420d
ffmpeg: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=3881606240953b9275a247a1c98a567f3c44890f

Search for package or bug name: Reporting problems