CVE-2014-9620

NameCVE-2014-9620
DescriptionThe ELF parser in file 5.08 through 5.21 allows remote attackers to cause a denial of service via a large number of notes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3121-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)wheezy5.11-2+deb7u8fixed
wheezy (security)5.11-2+deb7u9fixed
jessie1:5.22+15-2+deb8u3fixed
stretch (security), stretch1:5.30-1+deb9u1fixed
buster, sid1:5.32-1fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.21+15-1medium
filesourcesqueeze(not affected)
filesourcewheezy5.11-2+deb7u7mediumDSA-3121-1
php5source(unstable)(not affected)

Notes

[squeeze] - file <not-affected> (Introduced in 5.08)
- php5 <not-affected> (readelf.c not used and even removed in 5.4.36-0+deb7u3)
Report: http://mx.gw.com/pipermail/file/2014/001653.html
Fix: https://github.com/file/file/commit/ce90e05774dd77d86cfc8dfa6da57b32816841c4
Introduced by: https://github.com/file/file/commit/956a45ab1c54b11304b367056f41905e72a02380#diff-bc5c24ef9f39a5f4963ca28ecbc645b3L423

Search for package or bug name: Reporting problems