CVE-2014-9621

NameCVE-2014-9621
DescriptionThe ELF parser in file 5.16 through 5.21 allows remote attackers to cause a denial of service via a long string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)jessie1:5.22+15-2+deb8u4fixed
stretch1:5.30-1+deb9u2fixed
stretch (security)1:5.30-1+deb9u1fixed
buster, sid1:5.35-2fixed
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.39+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.21+15-1medium
filesourcesqueeze(not affected)
filesourcewheezy(not affected)
php5source(unstable)5.6.5+dfsg-1medium
php5sourcesqueeze(not affected)
php5sourcewheezy(not affected)

Notes

[wheezy] - file <not-affected> (Introduced in 5.16)
[squeeze] - file <not-affected> (Introduced in 5.16)
[wheezy] - php5 <not-affected> (Vulnerable code not present)
[squeeze] - php5 <not-affected> (Vulnerable code not present)
Report: http://mx.gw.com/pipermail/file/2014/001654.html
Fix: https://github.com/file/file/commit/65437cee25199dbd385fb35901bc0011e164276c
Introduced by: https://github.com/file/file/commit/c8451af8ab0c2e2a93ce93b9c68257d31576cc85 (5.16)
readelf.c has been removed in PHP in 5.6.5, see http://php.net/ChangeLog-5.php#5.6.5

Search for package or bug name: Reporting problems