CVE-2014-9625

NameCVE-2014-9625
DescriptionThe GetUpdateFile function in misc/update.c in the Updater in VideoLAN VLC media player before 2.1.6 performs an incorrect cast operation from a 64-bit integer to a 32-bit integer, which allows remote attackers to conduct buffer overflow attacks and execute arbitrary code via a crafted update status file, aka an "integer truncation" vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie (security), jessie2.2.7-1~deb8u1fixed
stretch (security), stretch3.0.8-0+deb9u1fixed
buster, buster (security)3.0.8-0+deb10u1fixed
bullseye, sid3.0.8-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)(not affected)
vlcsourcesqueeze(unfixed)end-of-life

Notes

- vlc <not-affected> (Update mechanism not enabled in the Debian package)
[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)
https://github.com/videolan/vlc/commit/fbe2837bc80f155c001781041a54c58b5524fc14

Search for package or bug name: Reporting problems