CVE-2014-9629

NameCVE-2014-9629
DescriptionInteger overflow in the Encode function in modules/codec/schroedinger.c in VideoLAN VLC media player before 2.1.6 and 2.2.x before 2.2.1 allows remote attackers to conduct buffer overflow attacks and execute arbitrary code via a crafted length value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3150-1
NVD severitymedium
Debian Bugs775866

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)stretch3.0.11-0+deb9u1fixed
stretch (security)3.0.11-0+deb9u2fixed
buster, buster (security)3.0.12-0+deb10u1fixed
bookworm, sid, bullseye3.0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcesqueeze(unfixed)end-of-life
vlcsourcewheezy2.0.3-5+deb7u2DSA-3150-1
vlcsource(unstable)2.2.0~rc2-2775866

Notes

[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)
https://github.com/videolan/vlc/commit/9bb0353a5c63a7f8c6fc853faa3df4b4df1f5eb5

Search for package or bug name: Reporting problems