CVE-2014-9636

NameCVE-2014-9636
Descriptionunzip 6.0 allows remote attackers to cause a denial of service (out-of-bounds read or write and crash) via an extra field with an uncompressed size smaller than the compressed field size in a zip archive that advertises STORED method compression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-150-1, DSA-3152-1
NVD severitymedium (attack range: remote)
Debian Bugs776589

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unzip (PTS)wheezy6.0-8+deb7u5fixed
wheezy (security)6.0-8+deb7u6fixed
jessie6.0-16+deb8u3fixed
jessie (security)6.0-16+deb8u2fixed
buster, stretch, sid6.0-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unzipsource(unstable)6.0-15medium776589
unzipsourcesqueeze6.0-4+deb6u2mediumDLA-150-1
unzipsourcewheezy6.0-8+deb7u2mediumDSA-3152-1

Notes

http://seclists.org/oss-sec/2014/q4/489
http://seclists.org/oss-sec/2014/q4/507
http://www.info-zip.org/phpBB3/viewtopic.php?f=7&t=450

Search for package or bug name: Reporting problems