CVE-2014-9637

NameCVE-2014-9637
DescriptionGNU patch 2.7.2 and earlier allows remote attackers to cause a denial of service (memory consumption and segmentation fault) via a crafted diff file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
patch (PTS)buster, buster (security)2.7.6-3+deb10u1fixed
bookworm, sid, bullseye2.7.6-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
patchsourcesqueeze(not affected)
patchsourcewheezy(not affected)
patchsource(unstable)2.7.1-7

Notes

[wheezy] - patch <not-affected> (Vulnerability introduced later)
[squeeze] - patch <not-affected> (Vulnerability introduced later)
https://savannah.gnu.org/bugs/?44051
http://git.savannah.gnu.org/cgit/patch.git/commit/?id=0c08d7a902c6fdd49b704623a12d8d672ef18944

Search for package or bug name: Reporting problems