CVE-2014-9652

NameCVE-2014-9652
DescriptionThe mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote attackers to cause a denial of service (out-of-bounds memory access and application crash) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-145-1, DSA-3121-1, DSA-3126-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)wheezy5.11-2+deb7u8fixed
wheezy (security)5.11-2+deb7u9fixed
jessie1:5.22+15-2+deb8u3fixed
stretch (security), stretch1:5.30-1+deb9u1fixed
buster, sid1:5.32-2fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u13fixed
jessie5.6.30+dfsg-0+deb8u1fixed
jessie (security)5.6.33+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.21+15-1medium
filesourcesqueeze(not affected)
filesourcewheezy5.11-2+deb7u7medium
php5source(unstable)5.6.5+dfsg-1medium
php5sourcesqueeze5.3.3-7+squeeze24mediumDLA-145-1
php5sourcewheezy5.4.36-0+deb7u3medium

Notes

[squeeze] - file <not-affected> (The code was not vulnerable, confirmed with Valgrind on the test data submitted to upstream)
http://bugs.gw.com/view.php?id=398
https://github.com/file/file/commit/59e63838913eee47f5c120a6c53d4565af638158
https://bugs.php.net/bug.php?id=68735

Search for package or bug name: Reporting problems