CVE-2014-9653

NameCVE-2014-9653
Descriptionreadelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory access) or possibly have unspecified other impact via a crafted ELF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-204-1, DSA-3196-1
Debian Bugs777585

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)stretch (security), stretch1:5.30-1+deb9u3fixed
buster1:5.35-4+deb10u2fixed
buster (security)1:5.35-4+deb10u1fixed
bullseye1:5.39-3fixed
bookworm, sid1:5.41-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesourcesqueeze5.04-5+squeeze10DLA-204-1
filesourcewheezy5.11-2+deb7u8DSA-3196-1
filesource(unstable)1:5.22+15-1777585
php5source(unstable)(not affected)

Notes

- php5 <not-affected> (readelf.c not used and even removed in 5.4.36-0+deb7u3)
http://bugs.gw.com/view.php?id=409
http://mx.gw.com/pipermail/file/2014/001649.html
https://www.openwall.com/lists/oss-security/2015/02/04/13

Search for package or bug name: Reporting problems