CVE-2014-9676

NameCVE-2014-9676
DescriptionThe seg_write_packet function in libavformat/segment.c in ffmpeg 2.1.4 and earlier does not free the correct memory location, which allows remote attackers to cause a denial of service ("invalid memory handler") and possibly execute arbitrary code via a crafted video that triggers a use after free.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-464-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.12-1~deb9u1fixed
buster, sid7:4.1-1fixed
libav (PTS)jessie6:11.12-1~deb8u1fixed
jessie (security)6:11.12-1~deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(not affected)
libavsource(unstable)6:11.2-1medium
libavsourcewheezy6:0.8.17-2+deb7u1mediumDLA-464-1

Notes

- ffmpeg <not-affected> (Vulnerable code not present in a ffmpeg version in the archive)
Patch in http://www.openwall.com/lists/oss-security/2015/01/04/10 seem to apply for libav
ffmpeg: https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=169065fbfb3da1ab776379c333aebc54bb1f1bc4
libav: https://git.libav.org/?p=libav.git;a=commit;h=b3f04657368a32a9903406395f865e230b1de348
http://www.openwall.com/lists/oss-security/2015/01/04/10

Search for package or bug name: Reporting problems