CVE-2014-9732

NameCVE-2014-9732
DescriptionThe cabd_extract function in cabd.c in libmspack before 0.5 does not properly maintain decompression callbacks in certain cases where an invalid file follows a valid file, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted CAB archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs774665

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmspack (PTS)jessie0.5-1+deb8u1fixed
jessie (security)0.5-1+deb8u3fixed
stretch0.5-1+deb9u3fixed
stretch (security)0.5-1+deb9u2fixed
buster0.8-1fixed
sid0.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmspacksource(unstable)0.5-1medium774665

Notes

http://www.openwall.com/lists/oss-security/2015/02/03/11

Search for package or bug name: Reporting problems