CVE-2014-9743

NameCVE-2014-9743
DescriptionCross-site scripting (XSS) vulnerability in the httpd_HtmlError function in network/httpd.c in the web interface in VideoLAN VLC Media Player before 2.2.0 allows remote attackers to inject arbitrary web script or HTML via the path info.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2vulnerable
jessie (security), jessie2.2.6-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
buster, sid2.2.6-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.2.0~rc2-1medium
vlcsourcesqueeze(unfixed)end-of-life
vlcsourcewheezy(unfixed)end-of-life

Notes

[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)
[wheezy] - vlc <end-of-life> (Unsupported in wheezy-lts)

Search for package or bug name: Reporting problems