DescriptionSquid 3.4.4 through 3.4.11 and through 3.5.1, when Digest authentication is used, allow remote authenticated users to retain access by leveraging a stale nonce, aka "Nonce replay vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs776464

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u3fixed
squid3 (PTS)wheezy3.1.20-2.2+deb7u4vulnerable
wheezy (security)3.1.20-2.2+deb7u8vulnerable
jessie (security)3.4.8-6+deb8u5fixed
stretch (security), stretch3.5.23-5+deb9u1fixed
buster, sid3.5.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(not affected)


- squid <not-affected> (related code not present in 2.7.X)
[wheezy] - squid3 <no-dsa> (Minor issue)
[squeeze] - squid3 <no-dsa> (Minor issue) (Squid 3.4) (Squid 3.5)

Search for package or bug name: Reporting problems