CVE-2014-9756

NameCVE-2014-9756
DescriptionThe psf_fwrite function in file_io.c in libsndfile allows attackers to cause a denial of service (divide-by-zero error and application crash) via unspecified vectors related to the headindex variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-356-1, DLA-928-1
NVD severitymedium (attack range: remote)
Debian Bugs804447

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)wheezy1.0.25-5vulnerable
wheezy (security)1.0.25-9.1+deb7u4fixed
jessie1.0.25-9.1+deb8u1fixed
stretch1.0.27-3fixed
buster, sid1.0.28-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.25-10medium804447
libsndfilesourcejessie1.0.25-9.1+deb8u1medium
libsndfilesourcesqueeze1.0.21-3+squeeze2mediumDLA-356-1
libsndfilesourcewheezy1.0.25-9.1+deb7u1mediumDLA-928-1

Notes

https://github.com/erikd/libsndfile/commit/725c7dbb95bfaf8b4bb7b04820e3a00cceea9ce6

Search for package or bug name: Reporting problems