CVE-2014-9761

NameCVE-2014-9761
DescriptionMultiple stack-based buffer overflows in the GNU C Library (aka glibc or libc6) before 2.23 allow context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long argument to the (1) nan, (2) nanf, or (3) nanl function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-411-1
NVD severityhigh (attack range: remote)
Debian Bugs813187

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10vulnerable
wheezy (security)2.13-38+deb7u12vulnerable
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch (security), stretch2.24-11+deb9u1fixed
buster, sid2.24-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)high
eglibcsourcesqueeze2.11.3-4+deb6u9highDLA-411-1
glibcsource(unstable)2.23-1high813187

Notes

[jessie] - glibc <no-dsa> (Minor issue)
[wheezy] - eglibc <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=16962
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=e02cabecf0d025ec4f4ddee290bdf7aadb873bb3
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=8f5e8b01a1da2a207228f2072c934fa5918554b8
Fixed for 2.23 upstream

Search for package or bug name: Reporting problems