CVE-2014-9763

NameCVE-2014-9763
Descriptionimlib2 before 1.4.7 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted PNM file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-401-1, DSA-3537-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imlib2 (PTS)wheezy, wheezy (security)1.4.5-1+deb7u2fixed
jessie (security), jessie1.4.6-2+deb8u2fixed
buster, sid, stretch1.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imlib2source(unstable)1.4.7-1medium
imlib2sourcejessie1.4.6-2+deb8u1mediumDSA-3537-1
imlib2sourcesqueeze1.4.2-8+deb6u1mediumDLA-401-1
imlib2sourcewheezy1.4.5-1+deb7u1mediumDSA-3537-1

Notes

https://git.enlightenment.org/legacy/imlib2.git/commit/?h=v1.4.7&id=c21beaf1780cf3ca291735ae7d58a3dde63277a2

Search for package or bug name: Reporting problems