CVE-2014-9766

NameCVE-2014-9766
DescriptionInteger overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-429-1, DSA-3525-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pixman (PTS)wheezy, wheezy (security)0.26.0-4+deb7u2fixed
jessie0.32.6-3fixed
buster, stretch, sid0.34.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pixmansource(unstable)0.32.6-1high
pixmansourcesqueeze0.16.4-1+deb6u2highDLA-429-1
pixmansourcewheezy0.26.0-4+deb7u2highDSA-3525-1

Notes

https://lists.freedesktop.org/archives/pixman/2014-April/003244.html
https://bugzilla.redhat.com/show_bug.cgi?id=972647

Search for package or bug name: Reporting problems