CVE-2014-9769

NameCVE-2014-9769
Descriptionpcre_jit_compile.c in PCRE 8.35 does not properly use table jumps to optimize nested alternatives, which allows remote attackers to cause a denial of service (stack memory corruption) or possibly have unspecified other impact via a crafted string, as demonstrated by packets encountered by Suricata during use of a regular expression in an Emerging Threats Open ruleset.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs819050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)stretch2:8.39-3fixed
buster2:8.39-12fixed
bullseye2:8.39-13fixed
bookworm, sid2:8.39-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3sourcewheezy(not affected)
pcre3sourcejessie2:8.35-3.3+deb8u4
pcre3source(unstable)2:8.38-1819050

Notes

[wheezy] - pcre3 <not-affected> (Vulnerable code not present)
Upstream fix: http://vcs.pcre.org/pcre?view=revision&revision=1475 (8.36)
Introduced in: http://vcs.pcre.org/pcre?view=revision&revision=1434 (8.35)
https://www.openwall.com/lists/oss-security/2016/03/26/1

Search for package or bug name: Reporting problems